Join the ongoing conversation on Discord:

Please read the current update for instructions on downloading the latest update. Players with Mac versions of the game will not be affected, but you will have a slightly longer wait for your version of the new maps. Please make a copy of your character folder before running the new update, just to make sure you don't lose any of your custom work.

It looks like we can give everyone a list of minimum specs for running City of Titans. Please keep in mind that this is 'for now' until we are able to add more graphics and other system refinements. Currently you will need :
Windows 10 or later required; no Intel integrated graphics like UHD, must have AMD or NVIDIA card or discrete chipset with 4Gb or more of VRAM
At least 16GB of main DRAM.
These stats may change as we continue to test.

To purchase your copy of the City of Titans Launcher, visit our store at A purchase of $50 or more will give you a link to download the Launcher for Windows or Mac based machines.

Kick attack teleported me into the ocean

2 posts / 0 new
Last post
Last seen: 2 weeks 4 days ago
kickstarter11th Anniversary Badge
Joined: 10/18/2013 - 06:49
Kick attack teleported me into the ocean

I was trying out the newest version and was enjoying it.
I was playing around with attacks and tried leaping on a mob and activating the kick attack as I was coming down. Both models started rotating around each other and ragdolling, then the screen flashed, I can't really describe it (multiple colors, multiple shapes and it lasted only a second or two) and then my camera was located at the bottom of the ocean, facing the direction of the mob I had targeted. After a second or two my character appeared in my camera view (simply appeared no noticeable motion with the appearance).
I tried repeating the the actions that lead to the bug but I was unable to recreate it.
Weird, I hope someone else can recreate it.

Last seen: 1 month 1 week ago
Joined: 10/29/2023 - 20:28
If your data is not

If your data is not completely lost, have you tried Ctrl shift T?
getting over it