Announcements

See our latest update! Next Steps for Building City of Titans!

Get the latest Patch now! The MacOS Client Launcher is Now available in the store! If you've already donated $50 or more, you'll find the Mac Launcher on your rewards page. https://store.missingworldsmedia.com/

Join the conversation on Discord: https://discord.gg/w6Tpkp2

"Fatal Error" when launching the character creator.

7 posts / 0 new
Last post
rawrey
Offline
Last seen: 3 weeks 18 hours ago
kickstarter
Joined: 10/01/2013 - 18:08
"Fatal Error" when launching the character creator.

I disabled all facets of Windows Defender and installed City of Titans from the store. When I launch it (it says connecting... but the read me says you don't need to wait for it to change) and "patch" it all I get is "Fatal Error" and the patch button disappears. All I can do is cancel. Anyone have any insight to what I should do?

System Specs:

Operating System: Windows 10 Home 64-bit (10.0, Build 18363) (18362.19h1_release.190318-1202)
Language: English (Regional Setting: English)
System Manufacturer: ASUSTeK COMPUTER INC.
System Model: ROG Zephyrus G14 GA401IV_GA401IV
BIOS: GA401IV.219 (type: UEFI)
Processor: AMD Ryzen 9 4900HS with Radeon Graphics (16 CPUs), ~3.0GHz
Memory: 16384MB RAM
Available OS Memory: 15790MB RAM
Page File: 9001MB used, 13956MB available
Windows Dir: C:\Windows
DirectX Version: DirectX 12
DX Setup Parameters: Not found
User DPI Setting: 120 DPI (125 percent)
System DPI Setting: 96 DPI (100 percent)
DWM DPI Scaling: Disabled
Miracast: Available, with HDCP
Microsoft Graphics Hybrid: Supported
DirectX Database Version: 1.2.0
DxDiag Version: 10.00.18362.0387 64bit Unicode

GRAPHICS

Card name: NVIDIA GeForce RTX 2060 with Max-Q Design
Manufacturer: NVIDIA
Chip type: GeForce RTX 2060 with Max-Q Design
DAC type: Integrated RAMDAC
Device Type: Full Device
Device Key: Enum\PCI\VEN_10DE&DEV_1F12&SUBSYS_1F111043&REV_A1
Device Status: 0180200A [DN_DRIVER_LOADED|DN_STARTED|DN_DISABLEABLE|DN_NT_ENUMERATOR|DN_NT_DRIVER]
Device Problem Code: No Problem
Driver Problem Code: Unknown
Display Memory: 13874 MB
Dedicated Memory: 5980 MB
Shared Memory: 7894 MB
Current Mode: Unknown
HDR Support: Unknown
Display Topology: Unknown
Display Color Space: Unknown
Color Primaries: Unknown
Display Luminance: Unknown
Driver Name: C:\Windows\System32\DriverStore\FileRepository\nvami.inf_amd64_9ec766fc3b32fb0e\nvldumdx.dll,C:\Windows\System32\DriverStore\FileRepository\nvami.inf_amd64_9ec766fc3b32fb0e\nvldumdx.dll,C:\Windows\System32\DriverStore\FileRepository\nvami.inf_amd64_9ec766fc3b32fb0e\nvldumdx.dll,C:\Windows\System32\DriverStore\FileRepository\nvami.inf_amd64_9ec766fc3b32fb0e\nvldumdx.dll
Driver File Version: 27.21.0014.6192 (English)
Driver Version: 27.21.14.6192
DDI Version: 12
Feature Levels: 12_1,12_0,11_1,11_0,10_1,10_0,9_3,9_2,9_1
Driver Model: WDDM 2.6
Graphics Preemption: Pixel
Compute Preemption: Dispatch
Miracast: Not Supported by Graphics driver
Detachable GPU: No
Hybrid Graphics GPU: Discrete
Power P-states: Not Supported
Virtualization: Paravirtualization
Block List: No Blocks
Catalog Attributes: Universal:False Declarative:True
Driver Attributes: Final Retail
Driver Date/Size: 3/9/2021 5:00:00 PM, 1049040 bytes
WHQL Logo'd: Yes
WHQL Date Stamp: Unknown
Device Identifier: Unknown
Vendor ID: 0x10DE
Device ID: 0x1F12
SubSys ID: 0x1F111043
Revision ID: 0x00A1
Driver Strong Name: oem76.inf:0f066de367514f4e:Section094:27.21.14.6192:pci\ven_10de&dev_1f12&subsys_1f111043
Rank Of Driver: 00CF0001
Video Accel: Unknown
DXVA2 Modes: DXVA2_ModeMPEG2_VLD DXVA2_ModeVC1_D2010 DXVA2_ModeVC1_VLD DXVA2_ModeH264_VLD_Stereo_Progressive_NoFGT DXVA2_ModeH264_VLD_Stereo_NoFGT DXVA2_ModeH264_VLD_NoFGT DXVA2_ModeHEVC_VLD_Main DXVA2_ModeHEVC_VLD_Main10 DXVA2_ModeMPEG4pt2_VLD_Simple DXVA2_ModeMPEG4pt2_VLD_AdvSimple_NoGMC DXVA2_ModeVP9_VLD_Profile0 DXVA2_ModeVP9_VLD_10bit_Profile2
Deinterlace Caps: n/a
D3D9 Overlay: Unknown
DXVA-HD: Unknown
DDraw Status: Enabled
D3D Status: Enabled
AGP Status: Enabled
MPO MaxPlanes: 0
MPO Caps: Not Supported
MPO Stretch: Not Supported
MPO Media Hints: Not Supported
MPO Formats: Not Supported
PanelFitter Caps: Not Supported
PanelFitter Stretch: Not Supported

warlocc
warlocc's picture
Offline
Last seen: 1 hour 4 min ago
Developerkickstarter
Joined: 09/20/2013 - 16:38
A fatal error usually means

A fatal error usually means the launcher can't access the manifest file.

If you disabled antivirus and firewall already, and tried running as admin, that means it's connection related.

Obviously your connection works, as you're posting here.

We've found a number of ISPs blocking our update server. If you can try with a VPN or alternative hotspot, and let us know your ISP and region, we can troubleshoot it further.

PR Team, Forum Moderator, Live Response Team

Iathor
Offline
Last seen: 17 hours 22 min ago
Developer
Joined: 07/16/2015 - 21:16
I’m betting your ISP is

I’m betting your ISP is Comcast out west somewhere; most of these issues seem to have come from there, though not all. Currently, our downloads come from our early test server, and if that gets blocked by the ISP, we don’t have an easy fix right now. And unfortunately, we’re not going to have any more luck talking to Comcast (or whoever) support than you are, probably less...

The current launcher is a fairly old piece of code created to handle the early alpha game downloads. However, there’s work in progress to move to a new launcher soon, which will support a more scalable download server solution. I can’t say quite when it will be ready, since we’re still dealing with some coding issues, but it’s not too far off. Once we can release that, we should be able to work around any blocks by switching to an alternate server.

And thanks for the comprehensive system report. In most cases, that would be very helpful. On this one, the ISP info would be the most helpful data.

I hope we’ll be able to get the new launcher out soon. Until we do, using.a VPN is probably the best workaround.

Tech Team

rawrey
Offline
Last seen: 3 weeks 18 hours ago
kickstarter
Joined: 10/01/2013 - 18:08
Thanks for your quick reply.

Thanks for your quick reply. I had tried all the above other than a VPN. I set up my hotspot, it worked very slowly. I purchased a VPN sub through PIA and it is downloading just fine now.

I have Comcast, so they appear to be blocking you.

Again, thanks for the quick reply!

Iathor
Offline
Last seen: 17 hours 22 min ago
Developer
Joined: 07/16/2015 - 21:16
Glad to hear it's working.

Glad to hear it's working. Sorry to put you through the workaround, but, sigh, alpha. Also sigh, Comcast. I have them too, but I'm on the east coast, and whatever is going on seems to be mostly localized to the western US.

Stuff is beginning to move toward release-grade code, at least in some areas, like the character creator. Though I need to take an axe to some of the older stuff that's still in there and clean it up. But it's working fine, so priority is on getting new parts of the system added. As it should be at this point. The new code that's in the upcoming release is much cleaner, fortunately. (Of course, I'd think that because I wrote a big chunk of it. It's so obvious how it works, really!)

Tech Team

dvirbl
Offline
Last seen: 3 days 11 hours ago
kickstarter11th Anniversary Badge
Joined: 05/03/2014 - 22:49
hi

hi

i just wanted to let you know i encountered this problem today too, first time it happened to me, before i could connect to the server without using a vpn with no problems.
i understand that for now i will need to use a vpn until things will be further along but just wanted to give you a heads up about this.
i'm from israel and my isp is bezeq international.
if any more info will be useful let me know what info you need and how to get it.

Iathor
Offline
Last seen: 17 hours 22 min ago
Developer
Joined: 07/16/2015 - 21:16
We have a fix in progress for

We have a fix in progress for this. The new launcher, which is already in use for Mac, will be coming to Windows as well. It supports failover to additional servers, so if one server gets blocked, it can move on to a different one.

Unfortunately, one of the libraries we used in the old Windows launcher suffered from bit-rot (it’s 32-bit only, and we needed to move to 64-bit). The Mac had an easy replacement, but on Windows, we’re working on writing a new version. As soon as we get that, we should be able to roll out the new launcher on Windows. I don’t have a solid timeframe for that, but hopefully it won’t be too long.

Tech Team